Cloud database outage

Incident Report for Atlas Status Page

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 07:53 UTC

Investigating

An issue with our cloud storage provider might create intermittent access issues to the platform.
Posted Mar 05, 2026 - 07:52 UTC
This incident affected: Shared Services (Visualization Content Services, PTC Account Services, Collaboration Service) and PTC Solutions Portal, PTC Admin Center, Kepware+, Creo+, Vuforia Expert Capture, Solution Manager.