Planned PTC Platform Scheduled Maintenance

Scheduled for Feb 25, 15:00 - 15:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 19, 2026 - 13:23 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 19, 2026 - 13:18 UTC

Scheduled

We will be undergoing scheduled maintenance between 9:00–9:30 AM CT. While no interruption is expected, a brief service disruption lasting a few seconds may occur.
Posted Feb 19, 2026 - 13:16 UTC
This scheduled maintenance affects: Vuforia Expert Capture and Solution Manager.