Azure Maintenance

Incident Report for Atlas Status Page

Resolved

This incident has been resolved.
Posted May 29, 2026 - 06:28 UTC

Update

We are continuing to monitor for any further issues.
Posted May 29, 2026 - 06:28 UTC

Monitoring

A fix has been provided by Azure. We are monitoring the status.
Posted May 29, 2026 - 06:22 UTC

Investigating

An unplanned maintenance procedure in Azure is creating intermittent issues in the Atlas platform. Incident is under investigation by Microsoft.
Posted May 29, 2026 - 06:03 UTC
This incident affected: Shared Services (Visualization Content Services, PTC Account Services, Collaboration Service) and PTC Solutions Portal, PTC Admin Center, Kepware+, Creo+, Vuforia Expert Capture, Solution Manager.