Elevated Authentication Errors

Incident Report for Atlas Status Page

Resolved

The incident has been resolved by our authentication provider. We will continue to monitor for any issues.
Posted Nov 18, 2025 - 16:42 UTC

Monitoring

We are experiencing intermittent failures with the ability to sign in. Our authentication provider has identified the issue and has implemented a fix. If you experience the failure we recommend signing in again.
Posted Nov 18, 2025 - 16:27 UTC
This incident affected: PTC Solutions Portal, PTC Admin Center, Kepware+, Creo+, Vuforia Expert Capture and Shared Services (PTC Account Services, Collaboration Service).