Upon further monitoring and investigation - the performance issues are more periodic and less frequent than initially assumed. We have identified improvements that are now in development and targeting to include those improvements in our next 3.26 (April) release. In the meantime, if you are experiencing long load-times - please contact Technical Support where we can verify if it is a result of this issue and inform you when it has cleared.
Posted Feb 25, 2026 - 18:15 UTC
Update
While the situation has improved, we are still seeing some rare intermittent load spikes. We continue to monitor the situation while working on further mitigations.
Posted Feb 14, 2026 - 19:48 UTC
Monitoring
A mitigation has been deployed at around 2026-02-12 8:50 UTC and we are monitoring the situation.
Posted Feb 12, 2026 - 09:29 UTC
Identified
The issue has been identified and a mitigation is currently implemented and tested. We plan to provide a hotfix during this week, while we continue to monitor the situation.
Posted Feb 10, 2026 - 11:00 UTC
Investigating
Vuforia Vantage (Mobile) as well as 2D procedures in Vantage Web are unaffected. It appears to be an intermittent issue, and a potential root cause is currently under investigation. We are monitoring the situation and are preparing a workaround.