PTC platform connectivity issues

Incident Report for Atlas Status Page

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 23:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2025 - 22:34 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 31, 2025 - 18:01 UTC

Identified

We’re currently investigating an issue with our configuration service that supports authentication and secure connections. Some customers may experience intermittent errors or see certain features fail to load.
Our engineering team is actively working to identify the root cause and restore normal operations. Further updates will be provided as progress continues.
Posted Oct 31, 2025 - 14:02 UTC
This incident affected: Shared Services (Visualization Content Services, PTC Account Services, Collaboration Service) and PTC Solutions Portal, PTC Admin Center, Kepware+, Creo+, Vuforia Expert Capture.